WordPress 5.4 Beta 1 Ready for Testing and Feedback

February 13, 2020

Release coordinator Francesca Marano announced the release of WordPress 5.4 Beta 1 on February 11. Most of the work has centered on the block editor. However, at the moment, contributors have closed another 258 tickets for the 5.4 milestone.

A second beta release is scheduled for February 18, according to the 5.4 release schedule, along with follow-up betas and release candidates in the following weeks. The final release of WordPress 5.4 is slated for March 31.

At this point in the development cycle, WordPress 5.4 is in a feature freeze, which means no new enhancements or feature requests will be considered. Only bug fixes and inline documentation are planned for the remainder of the cycle.

Developers should follow the beta testing handbook page to test their plugins and themes. Users who want to try out the upcoming release can do so via the WordPress Beta Tester plugin.

Block Editor Changes

wordpress-5-4-beta-1-ready-for-testing-and-feedback WordPress 5.4 Beta 1 Ready for Testing and Feedback
New welcome modal for the block editor.

WordPress 5.4 will comprise of 10 major releases of the Gutenberg plugin, which is the development project behind the block editor. The oldest update, version 6.6, was released on October 2. The latest update, version 7.5, landed on February 12.

For end-users who are still using the classic editor, version 5.4 is an opportunity to see if the block editor has improved enough to use. While it may not be ready for everyone, the user experience continues to get better with each release.

The block editor will feel much improved to users who have not yet tested the new features within the Gutenberg plugin. There is a welcome modal to introduce end-users to the block editor, which probably should have been added in WordPress 5.0 when the block editor landed. This update will also feature two new blocks: a social links block and a buttons group block.

The new navigation block will not land in WordPress 5.4. “The Navigation block is usable right now,” said Mark Uraine in a post explaining the decision. “But we don’t think it’s useful yet – at least not until it has an intuitive place to live.” The goal is for it to be available to users in the context of adding it to the header, footer, or sidebar rather than post content. It will make more sense for it to land in an update that branches the block system outside of the content area.

Several blocks now have extra text and background color settings, including gradient backgrounds. Users can set the image size for galleries, drag and drop a featured image, and change the title attribute for the image block. Multi-block selection is much improved along with numerous other user experience and accessibility improvements.

The following is, mostly, our coverage of each major Gutenberg release, dating back to version 6.6, along with a few links to the release announcements for versions we did not cover:

Important Developer Changes

Developers should begin testing their plugins and themes to make sure there are no breaking changes with the 5.4 beta release. Most changes will be with the block editor. However, there are some noteworthy updates to other areas of WordPress.

The get_calendar() function and anything that uses it, such as the calendar widget, have a breaking HTML change. The previous and next month links have been moved below the <table> element and within a new <nav> element. This may potentially break calendar designs for theme authors.

A new apply_shortcodes() function was added as an alias for do_shortcode(). The purpose of the function was to distinguish between do_* functions, which imply an action, and apply_* functions, which imply a filter or something that should return a value. It is purely a semantic change. It would be nice to see further cleanup of the function-naming mess that represents much of WordPress’ core code. With 16 years of technical debt, it could use an overhaul. Perhaps the acceptance of this four-year-old ticket on a simple shortcode function can start a trend.

Like plugins, themes can now set minimum version support. By using the Requires at least and Requires PHP headers in a theme’s style.css file, theme authors can set the minimum WordPress version and PHP version, respectively.

Source

Share this article:
 

eHost managed wordpress hosting

We’re listening.

Have something to say about this article? Share it with us on Facebook, Twitter or LinkedIn:

SHARE IT HERE:

Related Posts

Yoast SEO 13.1: Schema.org structured data enhancements

Yoast SEO 13.1: Schema.org structured data enhancements

Edwin Toonen Edwin is a strategic content specialist. Before joining Yoast, he spent years honing his skill at The Netherlands’ leading web design magazine. Yoast SEO 13.1 and WooCommerce SEO 12.6 are out today! In these two updated SEO plugins, you’ll find several...

Get ALL Your SEO, WordPress & Divi News

Join Our Daily Roundup

SEO News and More

SEO News and More

Subscribe ToThe Weekly SEO Trade News Updates

Get the latest SEO, SEM and SMM marketing intel, tips and tricks from one of the best SEO Gurus online. 

Every Tuesday morning we send out an aggregated email listing all new posts on SEO Trade News.

Excellent! Now check your email to confirm your subscription.